Wednesday, June 8, 2011

Configure BGP

Configure BGP to Communicate between two ASes






Router 1 Config:

!
interface FastEthernet0/0
 ip address 172.16.19.19 255.255.0.0
 duplex auto
 speed auto
!
!
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
!
R1(config)#router bgp 200

R1(config-router)#neighbor 3.3.3.1 remote-as 100

R1(config-router)#neighbor 3.3.3.1 ebgp-multihop 2

R1(config-router)#neighbor 3.3.3.1 update-source loopback 1

R1(config)#ip route 0.0.0.0 0.0.0.0 3.3.3.1

Router 2 Configuration:

!
interface Loopback0
 ip address 40.40.40.40 255.255.255.255
!

!
interface FastEthernet0/0
 ip address 3.3.3.1 255.255.255.0
 duplex auto
 speed auto
!


R2(config)#router bgp 100

R2(config-router)#neighbor 3.3.3.2 remote-as 200

R2(config-router)#neighbor 3.3.3.2 ebgp-multihop 2

R2(config-router)#neighbor 3.3.3.2 update-source loopback 0

R2(config)#ip route 0.0.0.0 0.0.0.0 3.3.3.2


R2#sh ip bgp neighbors
BGP neighbor is 3.3.3.2,  remote AS 200, external link
  BGP version 4, remote router ID 36.36.36.36
  BGP state = Established, up for 00:34:04
 <output truncated>

R2#sh ip bgp summary
BGP router identifier 3.3.3.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.2         4   200      38      38        1    0    0 00:34:28        0


R2#ping 33.33.33.33

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

R1#sh ip bgp neighbors
BGP neighbor is 3.3.3.1,  remote AS 100, external link
  BGP version 4, remote router ID 3.3.3.1
  BGP state = Established, up for 00:38:08
 <output truncated>

R1#sh ip bgp summary
BGP router identifier 36.36.36.36, local AS number 200
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.1         4   100      42      42        1    0    0 00:38:49        0

R1#ping 40.40.40.40

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.40.40.40, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Wednesday, June 1, 2011

Configuring EIGRP Routing


EIGRP Protocol:



Router 1 config:

interface FastEthernet0/0
 ip address 172.16.19.19 255.255.0.0
!
interface FastEthernet0/1
 ip address 3.3.3.2 255.255.255.0


R1(config-router)#network 172.16.0.0 0.0.255.255
R1(config-router)#network 3.3.3.0 0.0.0.255
R1(config-router)#no auto-summary

Router 2 Config:

interface FastEthernet0/0
 ip address 3.3.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 64
 ip address 2.2.2.2 255.255.255.0
 clockrate 128000
!

R2(config)#router eigrp 100
R2(config-router)#network 2.2.2.0 0.0.0.255
R2(config-router)#network 3.3.3.0 0.0.0.255
R2(config-router)#no auto-summary

Router 3 Config:

interface Serial0/0
 ip address 2.2.2.1 255.255.255.0
!
interface Serial0/1
 ip address 1.1.1.2 255.255.255.0
!

R3(config)#router eigrp 100
R3(config-router)#network 1.1.1.0 0.0.0.255
R3(config-router)#network 2.2.2.0 0.0.0.255
R3(config-router)#no auto-summary

Router 4 Config:
!
interface FastEthernet0/0
 ip address 172.16.20.20 255.255.0.0
!
interface Serial0/1
 bandwidth 64
 ip address 1.1.1.1 255.255.255.0
 clockrate 128000
!


R4(config)#router eigrp 100
R4(config-router)#network 1.1.1.0 0.0.0.255
R4(config-router)#no auto-summary

Check your Routing status by,


R1#sh ip route eigrp
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/41026560] via 3.3.3.1, 00:11:23, FastEthernet0/1
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/40514560] via 3.3.3.1, 00:11:23, FastEthernet0/1


R2#sh ip route eigrp
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/41024000] via 2.2.2.1, 00:11:01, Serial0/0
D    172.16.0.0/16 [90/30720] via 3.3.3.2, 00:11:01, FastEthernet0/0


R3#sh ip route eigrp
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2172416] via 2.2.2.2, 00:34:09, Serial0/0
D    172.16.0.0/16 [90/2174976] via 2.2.2.2, 00:34:09, Serial0/0


R4#sh ip route eigrp
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/41024000] via 1.1.1.2, 00:33:04, Serial0/1
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/41026560] via 1.1.1.2, 00:33:04, Serial0/1

Also check topology generated by DUAL algorithm in EIGRP by,


R1#sh ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(36.36.36.36)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.0/24, 1 successors, FD is 41026560
        via 3.3.3.1 (41026560/41024000), FastEthernet0/1
P 2.2.2.0/24, 1 successors, FD is 40514560
        via 3.3.3.1 (40514560/40512000), FastEthernet0/1
P 3.3.3.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/1
P 172.16.0.0/16, 1 successors, FD is 28160
        via Connected, FastEthernet0/0